欢迎光临
我们一直在努力

做一个选股公式(运气好的买家图)

买主,做个,公式,选股,天缘,将(天缘买主图)做个选股公式

将(天缘买主图)做个选股公式

编写条件:

请各位老师将(天缘买主图)做个选股公式,谢谢!!!
要求是:当主图同时出现(天缘买和买)字,请老师帮忙做个选股!!!
源码:
工作线:=MA(CLOSE,1);
趋势线:MA(CLOSE,18)COLORGREEN,LINETHICK2;
强势线:MA(CLOSE,3)COLORRED,LINETHICK2;
TT2:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9);
TT1:=REF(EMA(TT2,3),1);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE – LC),0),3,1) / SMA(ABS((CLOSE – LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
稻壳1:EMA(CLOSE,144),POINTDOT,COLORWHITE;
稻壳2:EMA(C,318);
AA1:=AMOUNT/VOL;
BB1:=L1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=VOL<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
F:=100*(C-REF(C,1))/REF(C,1);
P1:=IF(C<REF(O,1) AND F<0,1,0);
P2:=IF(C<REF(O,2) AND F<0,1,0);
TT3:=P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1 ;
TT4:=P1=1 AND REF(P1,1)=0 AND P2=1 AND REF(P2,1)=0 ;
Z1:=MA(C,13);
ZX:=REF(Z1,13/2+1);
DRAWICON(CROSS(ZX,C),H*1.01,2);
DRAWTEXT(CROSS(工作线,趋势线)AND J<55,LOW,'入')COLORWHITE;
DRAWTEXT(CROSS(CLOSE,TT1)AND J<55,LOW,'买'),COLORRED;
DRAWTEXT(CROSS(88,RSI),HIGH * 1.02,'顶'),COLOR00FFFF;
DRAWTEXT(FF1,L*0.99,'超短'),COLOR00FF00;
STICKLINE(TT3,OPEN,CLOSE,3,0),COLORFF00FF;
STICKLINE(TT4,OPEN,CLOSE,3,0),COLORGREEN;
TT5:=5;
V1:=MA(HIGH,30)*1.15;
V2:=MA(HIGH,3)*1.03;
V3:=MA(LOW,3)*0.97;
V4:=MA(LOW,30)*0.85;

N:=10;
T1:=CONST(HHVBARS(V,N));
T0:IF(CURRBARSCOUNT 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI – PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) – CLOSE)) / (HHV(HIGH,10) – LLV(LOW,10)));
NEWVOL:=(RSI5 – WR10);
天缘买:=(AV + NEWVOL);
DRAWTEXT(CROSS(天缘买,0),L*0.95,’天缘买’),COLORFF00FF;
DRAWICON(CROSS(天缘买,-5),L*0.98,1);
{AND 天缘买>REF(天缘买,1)};

成本:(MA(CLOSE,60)+MA(CLOSE,70)+MA(CLOSE,90)+MA(CLOSE,108))/4,COLORRED,LINETHICK2;

VAR2:=CLOSE*VOL;
VAR3:=EMA((EXPMA(VAR2,3)/EXPMA(VOL,3)+EXPMA(VAR2,6)/EXPMA(VOL,6)+EXPMA(VAR2,12)/EXPMA(VOL,12)+EXPMA(VAR2,24)/EXPMA(VOL,24))/4,N);
SUP:1.06*VAR3;
SDN:VAR3*0.94;
VAR4:=EXPMA(CLOSE,9);
LUP:EXPMA(VAR4*1.14,5);
LDN:EXPMA(VAR4*0.86,5);

A1AA:=9;
A2AA:=(REF(CLOSE,A1AA+1)-0.5),84),(HIGH)*(1.03),’小心变盘’),COLORFFFFFF;

周二:=WEEKDAY=2;
周O:IF(WEEKDAY>1,REF(O,周二),REF(C,WEEKDAY)),NODRAW;
周C:C,NODRAW;
周H:HHV(H,WEEKDAY),NODRAW;
周L:LLV(L,WEEKDAY),NODRAW;
周量:SUM(V,WEEKDAY),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,周H,周H,50,-1),COLORCYAN;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,周L,周L,50,-1),COLORLIRED;

编写方法:

TT2:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9);

TT1:=REF(EMA(TT2,3),1);

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

LC:=REF(CLOSE,1);

RSI5:=((SMA(MAX((CLOSE – LC),0),5,1) / SMA(ABS((CLOSE – LC)),5,1)) * 100);

TR1:=SUM(MAX(MAX((HIGH – LOW),ABS((HIGH – REF(CLOSE,1)))),ABS((LOW – REF(CLOSE,1)))),10);

HD:=(HIGH – REF(HIGH,1));

LD:=(REF(LOW,1) – LOW);

DMP:=SUM(IF(((HD 0) AND (HD LD)),HD,0),10);

DMM:=SUM(IF(((LD 0) AND (LD HD)),LD,0),10);

PDI:=((DMP * 100) / TR1);

MDI:=((DMM * 100) / TR1);

ADX:=MA(((ABS((MDI – PDI)) / (MDI + PDI)) * 100),5);

AV:=(RSI5 + ADX);

WR10:=((100 * (HHV(HIGH,10) – CLOSE)) / (HHV(HIGH,10) – LLV(LOW,10)));

NEWVOL:=(RSI5 – WR10);

天缘买:=(AV + NEWVOL);

XG:CROSS(天缘买,0) AND CROSS(CLOSE,TT1) AND J55;

买主,做个,公式,选股,天缘#将(天缘买主图)做个选股公式

版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权 , 未经允许不得转载:99财经网 » 做一个选股公式(运气好的买家图)

评论 抢沙发