欢迎光临
我们一直在努力

大智慧预测明天的股价指数公式

股价,大智慧,公式,明日,指标,预测,大智慧预测明日股价指标公式

大智慧预测明日股价指标公式

N:=(27);

开盘价:open,linethick0;

开盘价1:=REF(open,1);

最高价:high,linethick0;

最高价1:=REF(high,1);

最低价:low,linethick0;

最低价1:=REF(low,1);

收盘价:CLOSE,linethick0;

收盘价1:=REF(CLOSE,1);

{预测高低指标1}

A1:=REF(开盘价,1);

A2:=ABS((REF(收盘价,1)-A1)/A1);

A3:=ABS((REF(最高价,1)-A1)/A1);

A4:=ABS((REF(最低价,1)-A1)/A1);

B1:=ABS((A2+A3+A4)/3);

B2:=开盘价*B1;

{预测指标2}

AA:=最高价1;

BB:=最低价1;

CC:=开盘价1;

DD:=收盘价1;

EE:=(AA+BB+CC+2*DD)/5;

AAA:=EE+(AA-BB);

BBB:=2*EE-BB;

CCC:=2*EE-AA;

DDD:=EE-(AA-BB);

上升突破价:=AAA;

上升阻力价:=BBB;

下跌支撑价:=CCC;

下跌反转价:=DDD;

EEE:=(EE+上升突破价+上升阻力价+下跌支撑价+下跌反转价)/5;{心理价}

FFF:=(EEE+开盘价)/2;

{显示预测价}

预测低一:开盘价-B2,linethick0;

预测低二:(预测低一+FFF)/2,linethick0;

预测高一:开盘价+B2,linethick0;

{预测今日最高价指标}

预测高二:MA(REF(HIGH,1)/REF(CLOSE,2),N)*REF(CLOSE,1),linethick0;

差额一:=预测低一-low;

差额二:=预测低二-low;

差比一:=(差额一/low)*100;

差比二:=(差额二/low)*100;

{T + 0 操作数据}

pp:=0.0115;{可调整}

成本价:=预测低二*1.006;{也是买回价}

卖出价:成本价*(1+pp),linethick0;

高低差一:=预测高一-预测低二;

高低差二:=预测高二-预测低二;

差价比一:=卖出价/预测高一*100;

差价比二:=卖出价/预测高二*100;

今日高低比:=(最高价-最低价)/最高价*100;

昨日高低比:=(最高价1-最低价1)/最高价1*100;

{www.gupang.com 股旁网_大智慧股票指标公式}

DRAWTEXTREL(10,60,’ ★ 股票买入操作数据 ★’ ),coloryellow,linethick1;

DRAWTEXTREL(420,60,’ ★T + 0 操作数据★ 目前纯利设定为:’+NUMTOSTRN(ref(pp*100,0),2)+’%’+’ 股价高低比: ‘+NUMTOSTRN(ref(今日高低比,0),2)+’%’),coloryellow,linethick1;

DRAWTEXTREL(10,60,’最低价:’+NUMTOSTRN(ref(最低价,0),2) ),colorffffff,linethick2;

DRAWTEXTREL(320,60,’ 最高价:’+NUMTOSTRN(ref(最高价,0),2)),colorffffff,linethick2;

DRAWTEXTREL(10,200,’买入价预测 预测价 目前差价 目前差比’),COLORD3A9FF,linethick1;

DRAWTEXTREL(10,350,’ 预测低一 ‘+NUMTOSTRN(ref(预测低一,0),2)+’元 ‘+ NUMTOSTRN(ref(差额一,0),2)+’元 ‘+ NUMTOSTRN(ref(差比一,0),2)+’%’),colorffffff,linethick1;

DRAWTEXTREL(10,470,’ 预测低二 ‘+NUMTOSTRN(ref(预测低二,0),2)+’元 ‘+ NUMTOSTRN(ref(差额二,0),2)+’元 ‘+ NUMTOSTRN(ref(差比二,0),2)+’%’),colorffffff,linethick1;

DRAWTEXTREL(330,200,’卖出价预测 预测格 目前高低差 目前高低比 ★ 操作价格’),COLORD3A9FF,linethick1;

DRAWTEXTREL(330,350,’ 预测高一 ‘+NUMTOSTRN(ref(预测高一,0),2)+’元 ‘+ NUMTOSTRN(ref(高低差一,0),2)+’元 ‘+ NUMTOSTRN(ref(差价比一,0),2)+’%’),colorffffff,linethick1;

DRAWTEXTREL(330,470,’ 预测高二 ‘+NUMTOSTRN(ref(预测高二,0),2)+’元 ‘+ NUMTOSTRN(ref(高低差二,0),2)+’元 ‘+ NUMTOSTRN(ref(差价比二,0),2)+’%’),colorffffff,linethick1;

DRAWTEXTREL(600,350,’ 卖出价: ‘+NUMTOSTRN(ref(卖出价,0),2)+’元’),coloryellow,linethick1;

DRAWTEXTREL(600,470,’ 买回价: ‘+NUMTOSTRN(ref(预测低二,0),2)+’元’),coloryellow,linethick1;

{DRAWTEXTREL(750,470,’ 昨日高低比: ‘+NUMTOSTRN(ref(昨日高低比,0),2)+’%’),colorffffff,linethick1;}

ssu1:=卖出价预测高二 or 卖出价=预测高二;

ssu2:=卖出价预测高二;;

IF BARSTATUS=2 AND ssu1 THEN BEGIN

DRAWTEXTREL(750,250,’ ★ 设定成功’),COLORRED,linethick1;

END

ELSE

IF BARSTATUS=2 AND ssu2 THEN BEGIN

DRAWTEXTREL(750,250,’ ● 设定失败’),COLORgreen,linethick1;

END

su1:=预测低二low and 卖出价high;

su2:=预测低二low and 卖出价=high;

su3:=预测低二=low and 卖出价high;

su4:=预测低二=low and 卖出价=high;

su5:=预测低二low;

IF BARSTATUS=2 AND su1 THEN BEGIN

DRAWTEXTREL(750,370,’ ★ 操作成功’),COLORRED,linethick1;

END

ELSE

IF BARSTATUS=2 AND su2 THEN BEGIN

DRAWTEXTREL(750,370,’ ★ 操作成功’),COLORRED,linethick1;

END

ELSE

IF BARSTATUS=2 AND su3 THEN BEGIN

DRAWTEXTREL(750,370,’ ★ 操作成功’),COLORRED,linethick1;

END

ELSE

IF BARSTATUS=2 AND su4 THEN BEGIN

DRAWTEXTREL(750,370,’ ★ 操作成功’),COLORRED,linethick1;

END

ELSE

IF BARSTATUS=2 AND su5 THEN BEGIN

DRAWTEXTREL(750,370,’ ● 买回操作失败’),COLORgreen,linethick1;

END

su6:=卖出价high;

IF BARSTATUS=2 AND su6 THEN BEGIN

DRAWTEXTREL(750,480,’ ● 卖出操作失败’),COLORgreen,linethick1;

END

顶线:=80;

{黄金点:=-20;}

预测一:=-35;

预测二:=-50;

失败:=-65;

底线:=-75;

DRAWTEXT(DISPSTATUS=2,顶线,’ 80′),COLORred,ALIGN0;

{DRAWTEXT(DISPSTATUS=2,黄金点,’ 黄金买点’),COLORffffff,ALIGN0;}

DRAWTEXT(DISPSTATUS=2,预测一,’ 预测一’),COLORred,ALIGN0;

DRAWTEXT(DISPSTATUS=2,预测二,’ 预测二’),COLORyellow,ALIGN0;

DRAWTEXT(DISPSTATUS=2,失败,’ 未到位’),COLORgreen,ALIGN0;

DRAWTEXT(DISPSTATUS=2,底线,’ -75′),COLORgreen,ALIGN0;

{DRAWTEXT(lowhjmd,-20,’☆’),COLORffffff,ALIGN1;}

{DRAWTEXT(lowhjmd,-20,’●’),COLORgreen,ALIGN1;}

DRAWTEXT(low预测低一,-35,’☆’),COLORred,ALIGN1;

DRAWTEXT(low预测低二,-50,’☆’),COLORyellow,ALIGN1;

DRAWTEXT(low预测低二,-65,’●’),COLORgreen,ALIGN1;

{说明:红树林园 这一段源码做出来的效果是买点到位闪烁交替显示[☆到位]和[●失败]}

Amod:=MOD(CURRENTTIME,2);

DRAWTEXT(DISPSTATUS=2 and Amod=0,70,’预测提示’),colorffffff;

DRAWTEXT(DISPSTATUS=2 and Amod=1,70,’提示预测’),coloryellow;

DRAWTEXT(DISPSTATUS=2 and low预测低一 and Amod=0,10,’预测一 ☆’),colorred;

DRAWTEXT(DISPSTATUS=2 and low预测低一 and Amod=1,10,’预测一 ☆’),coloryellow;

DRAWTEXT(DISPSTATUS=2 and low预测低二 and Amod=0,-10,’预测二 ☆’),colorred;

DRAWTEXT(DISPSTATUS=2 and low预测低二 and Amod=1,-10,’预测二 ☆’),coloryellow;

DRAWTEXT(DISPSTATUS=2 and low预测低一 and Amod=0,10,’预测一 ●’),colorgreen;

DRAWTEXT(DISPSTATUS=2 and low预测低一 and Amod=1,10,’预测一 ●’),colorffffff;

DRAWTEXT(DISPSTATUS=2 and low预测低二 and Amod=0,-10,’预测二 ●’),colorgreen;

DRAWTEXT(DISPSTATUS=2 and low预测低二 and Amod=1,-10,’预测二 ●’),colorffffff;

DRAWTEXT(DISPSTATUS=2 and 卖出价high and Amod=0,50,’卖出价 ☆’),colorred;

DRAWTEXT(DISPSTATUS=2 and 卖出价high and Amod=1,50,’卖出价 ☆’),coloryellow;

DRAWTEXT(DISPSTATUS=2 and 卖出价high and Amod=0,50,’卖出价 ●’),colorgreen;

DRAWTEXT(DISPSTATUS=2 and 卖出价high and Amod=1,50,’卖出价 ●’),colorffffff;

DRAWTEXT(DISPSTATUS=2 and 预测低二low and Amod=0,30,’买回价 ☆’),colorred;

DRAWTEXT(DISPSTATUS=2 and 预测低二low and Amod=1,30,’买回价 ☆’),coloryellow;

DRAWTEXT(DISPSTATUS=2 and 预测低二low and Amod=0,30,’买回价 ●’),colorgreen;

DRAWTEXT(DISPSTATUS=2 and 预测低二low and Amod=1,30,’买回价 ●’),colorffffff;

股价,大智慧,公式,明日,指标,预测#大智慧预测明日股价指标公式

版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权 , 未经允许不得转载:99财经网 » 大智慧预测明天的股价指数公式

评论 抢沙发